OpenITG on Liunx Doesn't Work with Memory Cards

Anything concerning anything.

Moderators: Admins, Mods

Re: OpenITG on Liunx Doesn't Work with Memory Cards

Postby Horsey on Tue Mar 27, 2018 3:20 am

do you have the following in your Static.ini? (Drive letters will differ on your machine; you can find where your drives are mounted in fstab (I believe?). If you still can't figure it out, I'd recommend going on the facebook group here (ew, gross, I know): https://www.facebook.com/groups/565890830137096/

MemoryCardOsMountPointP1=L:/
MemoryCardOsMountPointP2=P:/
MemoryCardUsbPortP1=L:/
MemoryCardUsbPortP2=P:/
MemoryCardProfileImportSubdirs=In The Groove
MemoryCardProfileSubdir=In The Groove 2

MemoryCardUsbPortP1=-1
MemoryCardUsbPortP2=-1
MemoryCards=1
Image
Image
Community Dropbox Thread wrote:http://r21freak.com/phpbb3/viewtopic.php?f=6&t=24873
User avatar
Horsey
80%
80%
 
Posts: 1469
Joined: Sun May 01, 2011 3:00 pm
Location: Château Frontenac

Re: OpenITG on Liunx Doesn't Work with Memory Cards

Postby Faded_Memories on Tue Mar 27, 2018 1:22 pm

My fstab:

GNU nano 2.2.6 File: fstab Modified

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc nodev,noexec,nosuid 0 0
# / was on /dev/sda2 during installation
UUID=b087f798-4836-42a4-944f-ac47b7da669f / xfs defaults $
# /boot was on /dev/sda1 during installation
UUID=041c3d54-8e8c-450c-b6ad-5a44eced0d97 /boot xfs defaults $
# /itgdata was on /dev/sda5 during installation
UUID=d0ad4c9f-35e9-4926-b837-69066fe96d89 /itgdata xfs defaults $
# /stats was on /dev/sda3 during installation
UUID=f212f661-dc7c-4637-979d-4a41b4fc1f66 /stats xfs defaults $
/dev/sdb1 /media/itg/sdb1 vfat noauto 0 0
/dev/sdc1 /media/itg/sdc1 vfat noauto 0 0
/dev/sdd1 /media/itg/sdd1 vfat noauto 0 0
/dev/sde1 /media/itg/sde1 vfat noauto 0 0




those drive designations are in the media/itg directory too:

itg@itg:/media/itg$ ls
sdb1 sdc1 sdd1 sde1
itg@itg:/media/itg$

sdb1 sdc1 sdd1 sde1
itg@itg:/media/itg$ umount /dev/sdb1
umount: /dev/sdb1 is not mounted (according to mtab)
itg@itg:/media/itg$ sudo umount /dev.sdb1
[sudo] password for itg:
umount: /dev.sdb1: not found
itg@itg:/media/itg$ sudo umount /dev/sdb1
umount: /dev/sdb1: not mounted
itg@itg:/media/itg$ sudo umount /dev/sdb2
umount: /dev/sdb2: not found
itg@itg:/media/itg$ sudo umount /dev/sdc1
umount: /dev/sdc1: not mounted
itg@itg:/media/itg$ sudo umount /dev/sdd1
umount: /dev/sdd1: not found
itg@itg:/media/itg$ sudo umount /dev/sde1
umount: /dev/sde1: not found
itg@itg:/media/itg$
Faded_Memories
10%
10%
 
Posts: 12
Joined: Mon Dec 04, 2017 6:26 pm

Re: OpenITG on Liunx Doesn't Work with Memory Cards

Postby Faded_Memories on Tue Mar 27, 2018 1:27 pm

A friend of mine said something to me last night about Linux or Ubuntu wanting to mount devices directly, but the ITG software doesn't like that, wanting to mount them itself.

I'm wondering if there isn't something at the system level thats keeping this from working.

I can get the system to detect and mount drives, they just don't appear in the game like they should.
Faded_Memories
10%
10%
 
Posts: 12
Joined: Mon Dec 04, 2017 6:26 pm

Re: OpenITG on Liunx Doesn't Work with Memory Cards

Postby Faded_Memories on Sat Apr 28, 2018 4:35 pm

Bumping on the chance that someone new sees this or has a new idea to check.


Haven't been able to resolve this at all.

A few days ago I did find something new in my search that referenced some sort of bug in some version(s) of Ubuntu that had the Legacy support for floppy drives in BIOS messing up automatic mounting of usb devices. Toggling that off didn't seem to make a difference.

I have ZERO issues manually mounting the flash drives. I've added several additional song packs to the machine in the last couple of weeks. Plug the sticks into the Optiplex, ssh in from a Mac and copy everything over after stopping itg, unmounting /itgdata and remounting /dev/sda5 onto a temp directory to work from....

To reiterate a point that I think is relevant...the game obviously sees the hub and knows when it gets disconnected/reconnected. I just don't get any indication when I plug in or remove usb sticks.

Sunday night or Monday I may be able to post some details from the dmesg output. Maybe something there will jump out to someone for my solution?

We have a nice little core group of players getting together regularly now from the Richmond area and I'd really like to get the card functionality back to tie things together and make things even smoother for everyone.
Faded_Memories
10%
10%
 
Posts: 12
Joined: Mon Dec 04, 2017 6:26 pm

Re: OpenITG on Liunx Doesn't Work with Memory Cards

Postby TheKamilia on Sat Apr 28, 2018 11:16 pm

fixed it,

its called sm5
(づ。◕‿‿◕。)づ
User avatar
TheKamilia
20%
20%
 
Posts: 60
Joined: Sat May 06, 2017 10:28 am

Previous

Return to General Discussion

Who is online

Users browsing this forum: No registered users and 11 guests