oITG Arcade HDD failed. Need help building new (SSD) drive

Anything concerning anything.

Moderators: Admins, Mods

oITG Arcade HDD failed. Need help building new (SSD) drive

Postby Faded_Memories on Mon Dec 04, 2017 7:12 pm

A couple weeks ago my ITG started having issues booting and then stopped altogether.

I've had some help from friends but haven't been able to get the machine back to where it was.
.
Basically I've been able to install a couple various images to a new SSD to get ITG2 working stock, but every attempt to get to oITG has failed.

Stock Boxor kit. Was originally ITG. Korean Cab, CRT.

Attempts and errors:

Patching:
I'm quite confused on where exactly the "Patch.rsa" gets copied. I've seen instructions saying it goes in the "stats" folder, and others that state it goes in the root of one of the partitions. I've tried it both ways.

I've got as far as the machine saying that R21 or oITG installed successfully after that through the machine update in the menu, but I get a boot loop every time. Lots of errors about zips not being ITG data files and something about no secrets.


I've ended up with 2 copies of the ITGPro2 installer and one came from a friend who had verified its functionality. Once I put the installer on a USB stick it fails to boot.

I had been using SelfImage first and then lastly tried using YUMI.

I see some errors in the dialog/status window of YUMI about "copy failed" on some transfers and then again on the end. It does build a lot onto the target drives but nothing bootable shows up once I try to run it on the Boxor. I only see the option to continue booting from HDD (default).

I've tried using a couple of different options under "Try other unlisted ISO" and the end result is the same...nothing selectable comes up on the YUMI multiboot menu when booting from the stick.

I have tried 2 different brands of sticks. We are wondering if I need a larger one, even though I never got an actual message about a size problem.


This is driving me crazy. I recently put the machine back into operation, and it's the only one around so there are a lot of players, myself included, anxious to see the song catalog restored and even expanded.


I may need very detailed step by step help. I am really starting to think that there are some assumptions that just don't line up with my situation...

Maybe installers are looking for specific partitions and mine don't match? (Typical reference of hda3, but it is sdc3 on mine for example)

Are patches specific to particular builds, versions or even serial numbers? (Possible I'm mixing them up?)


I'm really hoping to just figure out how to get the patches to work, seems way easier than a complete installer. What would have been great would be to be able to figure out which files on my original drive were corrupted and just pasting new ones on to a full copy.

The original error that came up when the drive crapped out was about no remaining horizsync values. Could a single .ini file or similar somewhere be the missing link to fix the original boot failure???

I can send some pics of various error messages should someone opt to get involved here.

Any help much appreciated,
Thanks.
Faded_Memories
0%
0%
 
Posts: 3
Joined: Mon Dec 04, 2017 6:26 pm

Re: oITG Arcade HDD failed. Need help building new (SSD) dri

Postby concubidated on Mon Dec 04, 2017 9:12 pm

concubidated
10%
10%
 
Posts: 43
Joined: Mon May 07, 2007 11:58 pm
Location: Nor Cal

Re: oITG Arcade HDD failed. Need help building new (SSD) dri

Postby Faded_Memories on Mon Dec 04, 2017 11:23 pm

Those instructions aren't really all that complete/detailed for someone like myself whom hasn't done a similar process. Scroll down the page a bit and you see "after installation.." but no details on how to get there.

I can't boot the installer from the machine, so...

What do I start with?

Ubuntu? If yes, a live USB or does it have to be installed to the drive? And then what file do I launch, with what command?

I learn quick, but still have little Linux exposure. (I've gotten the hang of finding and mounting partitions the last week or so, and some basic file editing/copying. Much to learn yet of the basics.)
Faded_Memories
0%
0%
 
Posts: 3
Joined: Mon Dec 04, 2017 6:26 pm

Re: oITG Arcade HDD failed. Need help building new (SSD) dri

Postby Faded_Memories on Wed Dec 13, 2017 12:56 pm

Concubidated had contacted me for a bit more help. (Thanks!)

In case anyone else out there is reading and can chip in as well, here is where I stand now:


I installed the older Ubuntu server, partitioned the SSD and ran the installer over ssh from my Mac to the Boxor PC.

Got errors trying to install different video drivers, but the rest of the software seemed to install.

After install the "start" command gets a response that it is running, with a process number but nothing happens.
Conversely, the "stop" command gets an error message, "stop: Unknown instance:"

Definitely not auto starting. The system does boot, but will just sit at the itg login prompt.

After running fdisk with sudo, I can see that the partitions are there and I can mount them to new directories. Game data appears to be there.

May or may not be normal, but there is a message about not being able to read superblock on sda4.



So close, yet nothing....

Any help much appreciated.
Faded_Memories
0%
0%
 
Posts: 3
Joined: Mon Dec 04, 2017 6:26 pm


Return to General Discussion

Who is online

Users browsing this forum: No registered users and 2 guests

cron