Page 1 of 1

Got USBs working on itgPro2, not quite as expected though...

PostPosted: Mon May 14, 2018 3:30 pm
by Faded_Memories
I've been having trouble getting USB drives to work on my recent ITG system replacement and I started over last week.

After a couple days of boot issues I have a stable system again at home to play with, and I'm trying to get the USB sticks to work the way they USED to on ITG.

On Simply Love, the drives are recognized and keep stats, but what is driving me nuts is that they no longer keep track of the player's last used settings. (Last position on song wheel is remembered.)

I suspect this is because the cards are looking for options in a specific order, and the Mods menus are different between ITG and Simply Love.

My gut says this is a fixable problem if I can get things reordered to match between the ITG and SL themes. Not all of them since some are mutually exclusive, but looking for last speed modifier used, perspective, and noteskin preferences to stick from play to play...

Any ideas?



I just poked around on my card's Stats.xml file.
It appears that the card is noting/saving the various mods used but that Simply Love isn't loading them later.

I have tried editing some things in the Mods.lua script but nothing seemed to change. Not sure if I didn't rewrite the correct parts, or whether there is another step required. (Another file to edit, a forced re-load, compile etc?)

Re: Got USBs working on itgPro2, not quite as expected thoug

PostPosted: Thu May 17, 2018 10:23 pm
by TheKamilia
Faded_Memories wrote:I've been having trouble getting USB drives to work on my recent ITG system replacement and I started over last week.

After a couple days of boot issues I have a stable system again at home to play with, and I'm trying to get the USB sticks to work the way they USED to on ITG.

On Simply Love, the drives are recognized and keep stats, but what is driving me nuts is that they no longer keep track of the player's last used settings. (Last position on song wheel is remembered.)

I suspect this is because the cards are looking for options in a specific order, and the Mods menus are different between ITG and Simply Love.

My gut says this is a fixable problem if I can get things reordered to match between the ITG and SL themes. Not all of them since some are mutually exclusive, but looking for last speed modifier used, perspective, and noteskin preferences to stick from play to play...

Any ideas?



I just poked around on my card's Stats.xml file.
It appears that the card is noting/saving the various mods used but that Simply Love isn't loading them later.

I have tried editing some things in the Mods.lua script but nothing seemed to change. Not sure if I didn't rewrite the correct parts, or whether there is another step required. (Another file to edit, a forced re-load, compile etc?)


are you signing the profile data? also try adding it manually to the stats.xml and you should be able to set it in the static.ini as well